Home > An Error > An Error Occurred While Installing Pg 0.17.1

An Error Occurred While Installing Pg 0.17.1

Any suggestions? Or is it inevitable once a certain point in development is reached? Is there a command for running a script according to its shebang line? Nothing helps.. check over here

I have visited the following SO questions: An error occurred while installing pg (0.17.1), and Bundler cannot continue Installing pg -v 0.17.1 Installing PG gem on OS X - failure to If you are the application owner, check your logs for details." Any further thoughts would still be greatly appreciated. Thanks for the answer. –Deekor Apr 11 '14 at 0:07 Correct Bob, the version of postgresapp in which this worked for me, was Version 9.2.2.0, so they must have I've had to remove that because it threw up other issues. Bonuses

permalinkembedsaveparentgive gold[–]iv_jazz 2 points3 points4 points 1 year ago*(2 children)A working way is to get the Postgres.app and then install the gem with an argument for the path to pg_config (might be different Sigh, another OS upgrade headache. Push rejected, failed to compile Ruby app The first step mentioned in https://devcenter.heroku.com/articles/sqlite3 is to replace gem 'sqlite3' in my gemfile with gem 'pg'.

Please make sure you've tried searching Google and StackOverflow. Make sure that "gem install pg -v '0.18.1" succeeds before bundling. permalinkembedsavegive gold[–]ExNihil[S] 0 points1 point2 points 1 year ago(0 children)Yep. :-( permalinkembedsaveparentgive gold[–]Misaiato 0 points1 point2 points 1 year ago(1 child)You do have Postgresql itself installed first, right? rbenv local 2.1.2 instead of just running bundle install, install the gems in vendor/bundle bundle install --path vendor/bundle This did it for me.

Countries where lecture duration does not exceed one hour Where are my downvotes? Is there a special place where I'm suppose to install these commands? –maverick Dec 19 '13 at 9:45 check it out askubuntu.com/questions/295171/… –Pravin Mishra Dec 19 '13 at 10:21 Try /r/railsjobs, /r/forhire, or the following job sites: jobs.37signals.com jobs.github.com careers.stackoverflow.com Ruby Weekly Newsletter Ruby Inside rorjobs.com jobs.rubynow.com toprubyjobs.com a community for 8 yearsmessage the moderatorsMODERATORSbrendanlimbrentmc79adambairndbroadbentfqncmd-trailsbotnoodlezAutoModeratorabout moderation team »discussions in /r/rails<>X· 2 comments If you check these guys out Finding The nth Prime such that the prime - 1 is divisible by n History of differential form and vector calculus Making a radio wave/transmission waves Why is nuclear waste more

Please help! 9 Answers STAFF Naomi Freeman Treehouse Guest Teacher Naomi Freeman Naomi Freeman Treehouse Guest Teacher almost 3 years ago Database.yml: # SQLite version 3.x # gem install sqlite3 # Thanks. –Christopher Schneider Jan 28 '15 at 4:27 1 Thanks, this worked for me! –tomd Oct 16 '15 at 19:28 | show 1 more comment up vote 13 down vote The underlying problem was simpy that the since postgres was installed via the app, the configuration file resides on a location which is not the default one when installing it without Ulises Reyes 9,002 Points Ulises Reyes Ulises Reyes 9,002 Points almost 3 years ago Thanks.

share|improve this answer edited Feb 4 at 0:48 Ilya Cherevkov 664828 answered May 12 '15 at 5:50 phd 1481110 add a comment| up vote 4 down vote If you are using I fixed it with replacing the value of build.pg to: bundle config build.pg --with-pg-config=/usr/local/Cellar/postgresql/9.4.4/bin/pg_config which is where my postgresql installation is. Make sure that `gem install sqlite3 -v '1.3.8'` succeeds before bundling. ! ! What's the fastest way to generate a 1 GB file containing only random numbers?

There are so many people that have had trouble with this. http://missioncritiallinux.com/an-error/an-error-occurred-while-installing-acronis-true-image-home-2012.html It should look like this: group :development, :test do gem 'sqlite3' end group :production do gem 'pg' end Then do: bundle install --without=production That should get you running locally. If you found our advice to be useful, you might like our book about maintainable Rails applications: Check out our new e-book: Growing Rails Applications in Practice Learn to structure large How can I avoid it? –Roy Sep 18 '15 at 19:12 @Roy - glad to help :) - should be fine, probably want to avoid using sudo as I

Do only black holes emit gravitational waves? Linked -1 I git cloned a repo and I cannot run it on localhost because missing gem and cannot bundle install Related 1Using the “pg” gem with Rails 3 … why After finally being able to get past the permission denied key (heroku keys:add was not working) I still cant push into heroku. this content Is it finishing with success? –Jakub Niechciał May 11 '15 at 9:14 Is it possible that my .bash_profile is broken?

based on MAC address -- why not "based on MAC addresses"? Would this be considered as plagiarism? Then do this: sudo apt-get install libpq-dev … and run Bundler again.

Read more about it here.

For newer or older versions, replace 9.4 with the version. The solution appears that it may be related specifically to your OS. –Vince Dec 24 '13 at 2:58 You might want to visit . Make sure that gem install pg -v '0.18.1' succeeds before bundling. –phd May 11 '15 at 9:16 Hard to know. share|improve this answer edited Jul 22 '14 at 17:36 Marius Butuc 6,8561458100 answered Apr 21 '14 at 17:45 Shannon Perkins 18327 1 Thank you very much!

I know that in Windows, you have to install the binaries before expecting the gem to work. Learning Ruby? Does Harley Quinn ever have children? have a peek at these guys After exporting to path have you closed and open new session in terminal? –Jakub Niechciał May 11 '15 at 9:19 | show 7 more comments up vote 0 down vote PostgreSQL

booktown=# booktown=# \d (snip) public | subjects | table | postgres public | text_sorting | table | postgres booktown=# SELECT * FROM subjects; 0 | Arts | Creativity St 1 | I've forgotten the significance of this, but it basically allows the gem to run natively on the OS environment you're using. Are human fetal cells used to produce Pepsi? Make sure that `gem install rack -v '2.0.1'` succeeds before bundling3gem install pg for ruby on rails Hot Network Questions Is every non stationary series convertible to a stationary series through

Run bundle install to install missing gems. I keep getting the following issue: An error occurred while installing sqlite3 (1.3.8), and Bundler cannot continue. Make sure that gem install pg -v '0.17.1' succeeds before bundling. Mountainering with 6 y.o.

You may need configuration options. Excepted from this license are code snippets that are explicitely marked as citations from another source. Total 334 (delta 134), reused 0 (delta 0) -----> Ruby app detected -----> Compiling Ruby/Rails -----> Using Ruby version: ruby-2.0.0 -----> Installing dependencies using 1.5.2 New app detected loading default bundler Thx man!!! –Bozic Nebojsa May 9 '14 at 9:49 1 Still works!